WEBSITE ACCESSIBILITY
Incident Report for CVFD
Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 17:38 CDT
Investigating
Our content management system -- Weebly -- is experiencing issues.

Direct access to our website -- www.choctawfire.com -- and through direct links may not function, and may return an error. The issue has been identified and teams are working to correct the issue.

At this time, there is no time frame within which the issue will be resolved.
Posted Apr 27, 2023 - 10:21 CDT
This incident affected: Weebly.