SQUARE SERVICES DISRUPTION
Incident Report for CVFD
Resolved
This incident has been resolved.
Posted Feb 19, 2024 - 09:01 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2024 - 17:04 CST
Investigating
Our payment processor is currently experiencing a disruption that is impacting some Square services.

We understand how important it is for all of our services to be up and running, and we are actively working on a fix.

Thank you for your patience with us as we work to resolve this issue.
Posted Feb 18, 2024 - 16:50 CST
This incident affected: Square POS.