SQUARE SERVICES DISRUPTION
Incident Report for CVFD
Resolved
This incident has been resolved.
Posted Feb 23, 2023 - 10:40 CST
Identified
We are currently experiencing a disruption that is impacting some Square services.

We understand how important it is for all of our services to be up and running, and we are actively working on a fix.

Thank you for your patience with us as we work to resolve this issue.
Posted Feb 23, 2023 - 10:01 CST
This incident affected: Square POS.